#1 February 18, 2021 3:49pm

doon.mok
Member
Registered: May 6, 2015
Posts: 94

Google Analytics - Can't Authenticate

Hello,

I was getting a "No profiles were found in your Google Analytics account."under Analytics. Which was odd because it was working before. So I Disconnected and tried to Authenticate. I sign in with my email account and get warning below.

"Google hasn’t verified this app
The app is requesting access to sensitive info in your Google Account. Until the developer (info.fastspot@gmail.com) verifies this app with Google, you shouldn't use it."

I go to site to get code anyways and copy code. It says successfully authenticated but nothing happened.
I still get the "To connect Google..." and Enter Code Here field to authenticate. I tried hard refresh and logging in/out.
Any ideas why it is not connecting?

bigtree 4.4.12

Thanks

Offline

#2 February 18, 2021 8:55pm

timbuckingham
Administrator
From: Baltimore, MD
Registered: April 2, 2012
Posts: 924

Re: Google Analytics - Can't Authenticate

I'm guessing Google has deprecated the use of the very antiquated way we used to pull Analytics data without requiring OAuth / application creation on the client side. I just tested this out on a BigTree install and they're now hiding the option to continue behind clicking "Advanced" and then "Go to BigTree (unsafe)". It does look like if you proceed through those steps that the actual data connection still works though!

Offline

#3 February 22, 2021 9:35am

doon.mok
Member
Registered: May 6, 2015
Posts: 94

Re: Google Analytics - Can't Authenticate

Tim,

The code from google doesn't seem to be saving for me. When I go back to analytics, it is still asking to authenticate. I tried on my local and live websites. The token is empty.
Any ideas?

Thanks

Offline

#4 February 22, 2021 3:16pm

doon.mok
Member
Registered: May 6, 2015
Posts: 94

Re: Google Analytics - Can't Authenticate

The oAuthSetToken function doesn't seem to be creating the token. I even tried to Authenticate and Save Code without entering anything in the field and still gave me a success message.

Offline

Board footer

Powered by FluxBB

The Discussion Forum is not available on displays of this size.