#1 September 6, 2019 6:49am

benbakelaar
Member
Registered: September 6, 2019
Posts: 5

Out of box install has no CSS files (only LESS files)

I installed BigTree 4.4.6 successfully, and had it populate the demo site.

When the site loads, there are 404s for SITE.CSS, SITE.JS, and MODERNIZR.JS.

When I go in the file manager and browse to the /site/css, there are only 3 files there: COMMON.LESS, FORMS.LESS, and MAIN.LESS.

But the site index page is pointing to /SITE/CSS/SITE.CSS.

Trying to figure it out now, browsing through the documentation - but wanted to report it anyway in case this is a new issue with the latest version, as I don't see it mentioned in any prior forum posts.

-- Ben

Offline

#2 September 6, 2019 6:57am

benbakelaar
Member
Registered: September 6, 2019
Posts: 5

Re: Out of box install has no CSS files (only LESS files)

OK I found this: https://www.bigtreecms.org/about/help/

I'm seeing a page with broken styles or a 500 error after installing BigTree, what's up?

Many shared hosts have issues with .htaccess files. We have a section dedicated to some common platforms for installing BigTree where issues are known available here. If you're running into issues with your chosen host we're happy to help on the forum.

But actually, the problem doesn't seem to be with my host. When I unzip the archive, I'm not seeing an .htaccess file inside. And if it is generated upon install... I'm not seeing any .htaccess files having been created on the server. I have the File Manager settings turned on to show hidden files, I can see them in other web directories (like Wordpress).

Offline

#3 September 6, 2019 7:29am

benbakelaar
Member
Registered: September 6, 2019
Posts: 5

Re: Out of box install has no CSS files (only LESS files)

OK got it.

The bug - if it is a bug - is with the default "site routing" choice. Perhaps it is a combination of that with my particular host (inmotionhosting.com) but I don't think so. I think if you leave the default setting - then certain things aren't happening after install, the most obvious of which is the CSS file is not compiled. At this point even if you add in the .htaccess files manually, it still doesn't resolve the problem.

In the instructions:
https://www.bigtreecms.org/developers/d … tallation/

There is a very brief mention of site routing:

Site Routing

    You may choose what type of routing you would like to use for your BigTree site.

But it doesn't even mention the 3 options, or why you might choose one or the other, and also what potential issues you might encounter. So I think this part of installation instructions could be improved a bit - if someone on the project team responds, I can even take a pass at it.

For me, normally if I encountered an issue like this, I would just abandon and search for another codebase, assuming the code is just old/unsupported/not working.

Offline

#4 September 6, 2019 8:07am

timbuckingham
Administrator
From: Baltimore, MD
Registered: April 2, 2012
Posts: 883

Re: Out of box install has no CSS files (only LESS files)

I believe default routing does not use htaccess at all (it is for servers that do not support it). Instead it routes all URLs through /site/index.php/ which is ugly but should be supported at most hosts.

The example site does not use straight CSS files but does dynamic compilation of the LESS files you can see inside of /site/css/. The /custom/settings.php file has an array of files that it compiles when it looks for /site/index.php/css/site.css.

I just did a test install of this and it does look like the demo site is broken in Default routing (but works in the other two modes that use htaccess). I'll see if we can get this fixed in 4.4.7.

Offline

#5 September 6, 2019 8:59am

timbuckingham
Administrator
From: Baltimore, MD
Registered: April 2, 2012
Posts: 883

Re: Out of box install has no CSS files (only LESS files)

I have this fixed in the development branch if you want to patch in place:

https://github.com/bigtreecms/BigTree-C … 102f631525

Offline

#6 September 9, 2019 6:27pm

benbakelaar
Member
Registered: September 6, 2019
Posts: 5

Re: Out of box install has no CSS files (only LESS files)

Thanks very much!

Offline

Board footer

Powered by FluxBB

The Discussion Forum is not available on displays of this size.