#1 April 1, 2013 1:21pm

JeredOdegard
Member
Registered: March 29, 2013
Posts: 12

MtM Relationship Form Disappears When All Rows Used

I have three tables with modules set up for two. For example:

dogs: name, age (module)
treats: title (module)
dog_x_treat: dog_id, treat_id

If I have 3 treats and set my dog to like all of the treats in the New or Edit form, the MtM input box disappears. If I go and manually remove one of the associations in the database, the form re-appears. It seems that when all rows are associated to the object, it has logic to now show the input. This a problem however, should my dog's treat preferences change, I have no way of editing it as a front-end user.

I'm digging through the /core to try and make a fix. Having trouble finding the right files though. I'll be sure to make a pull request on Github if I patch it.

Offline

#2 April 1, 2013 1:33pm

timbuckingham
Administrator
From: Baltimore, MD
Registered: April 2, 2012
Posts: 932

Re: MtM Relationship Form Disappears When All Rows Used

This is fixed in the development branch. I'm not sure if it can be dropped-in to RC2 or not, but here's the development branch's drawing code for Many to Many:

https://github.com/bigtreecms/BigTree-C … o_many.php

Offline

#3 April 1, 2013 1:38pm

JeredOdegard
Member
Registered: March 29, 2013
Posts: 12

Re: MtM Relationship Form Disappears When All Rows Used

Just found it too. Thanks! Line 64 GRRR.

Offline

Board footer

Powered by FluxBB

The Discussion Forum is not available on displays of this size.