#1 July 6, 2017 8:52am

doon.mok
Member
Registered: May 6, 2015
Posts: 96

New install 404 error

Hello,

Hosting through InMotion, I installed BigTree but getting 404 errors on the homepage and admin page.
After the install, there were no errors/warnings but the Install Complete screen was without CSS(white background) and at first I got a 500 error when I went to the homepage/admin page. I followed your "Installing BigTree on 1and1 Hosting" instructions and added / in the  /.htaccess file, then got 404 error. Changed /site/.htaccess from your instructions but still getting 404 error.
Any ideas what could be wrong?

Thanks

Offline

#2 July 6, 2017 8:55am

timbuckingham
Administrator
From: Baltimore, MD
Registered: April 2, 2012
Posts: 932

Re: New install 404 error

I haven't personally tried out InMotion hosting but it sounds like you're running into the htaccess not being read and/or no support for modrewrite. You should be able to install BigTree with "Simple" routing (that directs all the urls through index.php like http://www.site.com/index.php/admin/) and avoid htaccess troubles. If you want nice clean URLs it's kind of trial and error figuring out what each host doesn't like about the default htaccess files but if they don't support modrewrite clean URLs are out altogether unfortunately.

Offline

#3 July 6, 2017 11:32am

doon.mok
Member
Registered: May 6, 2015
Posts: 96

Re: New install 404 error

Tim,

After doing some more research, in the error log
site/.htaccess: Invalid command 'php_flag', perhaps misspelled or defined by a module not included in the server configuration

The reason is InMotion uses SuPHP as its handler, from what I read I need to create a php.ini file. Do you recommend a different handler or create a php.ini file? They also have DSO, FCGI and CGI handlers available.


Doon

Offline

#4 July 6, 2017 11:33am

timbuckingham
Administrator
From: Baltimore, MD
Registered: April 2, 2012
Posts: 932

Re: New install 404 error

php_flag is used to turn on short tags. If InMotion already supports short_open_tag or you have access to set it to "on" in php.ini I'd drop that directive from htaccess.

Offline

#5 July 6, 2017 11:59am

doon.mok
Member
Registered: May 6, 2015
Posts: 96

Re: New install 404 error

Thanks Tim, for the quick reply.

For anyone else having this issue,

I removed these two lines from /site/.htaccess
php_flag short_open_tag On
php_flag magic_quotes_gpc Off

Created a php.ini file and added lines
short_open_tag = on;
magic_quotes_gpc = Off;
magic_quotes_runtime = Off;
magic_quotes_sybase = Off;

Offline

Board footer

Powered by FluxBB

The Discussion Forum is not available on displays of this size.