#1 March 28, 2013 1:01pm

etherealclarity
Member
Registered: March 7, 2013
Posts: 27

Blog Module Tagging

Hello!


I've been getting to know BigTree as I've been building out a site for a client and I have to say - I'm loving it so far!



So, my issue - I'm trying to use the blogging engine included in the example site. For the most part everything works great! However, I can't seem to figure out how to tag the blog posts. The layout files seem to have been built with tagging in mind, but when you go to add a post or edit a post there's no place for tags. Is this something that was never built out or am I missing something?

Offline

#2 March 28, 2013 1:05pm

benplum
Administrator
Registered: March 30, 2012
Posts: 54

Re: Blog Module Tagging

You'll need to enable tagging in the module. Head to the developer tab and edit the form for the blog posts. There should be a checkbox to enable tags.

Offline

#3 March 28, 2013 1:06pm

timbuckingham
Administrator
From: Baltimore, MD
Registered: April 2, 2012
Posts: 970

Re: Blog Module Tagging

I believe this is probably a bug in the example site for RC2. In a recent release we changed tags from being enabled by default (and thus more often than not they simply confused end users since they're not often used) to having to be explicitly enabled.

If you go into the developer section and edit the blog module's form for posts you should be able to re-enable tagging there (it should be a checkbox above the field area).

I'll make sure to have this fixed in the next release — thanks for the bug report!

Offline

#4 March 28, 2013 2:22pm

etherealclarity
Member
Registered: March 7, 2013
Posts: 27

Re: Blog Module Tagging

Thanks to you both! That did the trick.

Offline

#5 July 27, 2013 10:52am

ashuttl
Member
Registered: April 21, 2012
Posts: 1

Re: Blog Module Tagging

Does there need to be a field with a special name to enable tagging? I've enabled it for my module, and I'm seeing it on the form, but any tags I enter aren't saved.

Offline

#6 July 27, 2013 3:29pm

benplum
Administrator
Registered: March 30, 2012
Posts: 54

Re: Blog Module Tagging

No special fields are required. Tags are actually a relational system. The "bigtree_tags" table stores the actual tag (as well as metaphone info and a generated route), while the "bigtree_tags_rel" table stores the relationship between the tag and an individual page or module item. A basic SQL join is used to find tagged pages or module items, but you could always write a custom query to find everything related to a specific tag. Check out these tag related functions in the docs to help get you started:

http://www.bigtreecms.org/code-referenc … CMS.getTag
http://www.bigtreecms.org/code-referenc … TagByRoute

http://www.bigtreecms.org/code-referenc … agsForPage
http://www.bigtreecms.org/code-referenc … agesByTags

http://www.bigtreecms.org/code-referenc … agsForItem
http://www.bigtreecms.org/code-referenc … atedByTags

Offline

#7 February 5, 2015 4:00pm

taylorn16
Member
Registered: February 3, 2015
Posts: 3

Re: Blog Module Tagging

I know this is an old post, but does anyone have an answer to ashuttl's question? I'm experiencing the same thing: I can enter tags in the module form, but they aren't saved.

Offline

#8 February 6, 2015 11:39am

timbuckingham
Administrator
From: Baltimore, MD
Registered: April 2, 2012
Posts: 970

Re: Blog Module Tagging

As Ben mentioned above, no special fields are required. The relationship is stored in the `bigtree_tags_rel` table and the different tags are stored in `bigtree_tags`.
Do you see any content in those tables? Also, are you hitting enter after entering each tag (I totally understand this part isn't clear in the process -- we don't use tagging very often in our projects so it's not the most refined UX). You should see something like this after tagging an entry:

G2KIyxl.png

Offline

Board footer

Powered by FluxBB

The Discussion Forum is not available on displays of this size.