#1 September 22, 2016 1:16pm

doon.mok
Member
Registered: May 6, 2015
Posts: 96

Upgraded Form Builder and now using default styling

We are currently on version 4.2.13 of bigtree on our development website and upgraded to Form Builder 1.1 today but after the Form Builder upgrade, all of our Routed Templates Form Builder is now using the default styling from the Form Builder extension located

extensions/com.fastspot.form-builder/templates/routed/btx-form-builder

We are not sure why it is not using our \templates\routed\btx-form-builder page styling when view the page?

Thanks

Offline

#2 September 22, 2016 2:19pm

timbuckingham
Administrator
From: Baltimore, MD
Registered: April 2, 2012
Posts: 932

Re: Upgraded Form Builder and now using default styling

I'm not sure why that would happen - I don't see anything in BigTreeAdmin::installExtension that would update the pages table to switch a page's template. It does drop all the existing templates that "belong" to the extension before upgrading (so if the default Form Builder template that came with the Extension was customized the database entry for it would be replaced on upgrade). If the original database entry for the Form Builder template was deleted for a custom one in /templates/ you'll end up with two database entries for the template and you may end up adding pages with the Extension version instead -- maybe that's what you're seeing?

The 1.1 release of Form Builder does require some new fields from the template to implement the new auto-responder functionality. I'd take a look at it in a development environment and see if you can migrate the new fields over (once you get this worked out!). The easiest way to upgrade the pages would be to query directly in MySQL:

UPDATE bigtree_pages SET template = 'btx-form-builder' WHERE template = 'com.fastspot.form-builder*btx-form-builder'

Offline

#3 September 22, 2016 3:23pm

doon.mok
Member
Registered: May 6, 2015
Posts: 96

Re: Upgraded Form Builder and now using default styling

Hello Tim,

We looked in the dev database table bigtree_templates and we only see one row for the Form Builder

'com.fastspot.form-builder*btx-form-builder', 'Form Builder', 'on', ... ,'0', '0', '10', 'com.fastspot.form-builder'

We also haven't modified any files in the Form Builder extension.

Offline

#4 September 22, 2016 3:27pm

timbuckingham
Administrator
From: Baltimore, MD
Registered: April 2, 2012
Posts: 932

Re: Upgraded Form Builder and now using default styling

It's possible that the custom form builder template got duplicated from the com.fastspot.form-builder version and the "extension" column remained set to com.fastspot.form-builder -- that would have caused it to be wiped when the extension upgraded itself and replaced with the built-in version.

Offline

#5 September 22, 2016 3:33pm

doon.mok
Member
Registered: May 6, 2015
Posts: 96

Re: Upgraded Form Builder and now using default styling

Hello Tim,

I think we figured it out. After upgrading Form Builder, the id in bigtree_templates table was changed to com.fastspot.form-builder*btx-form-builder.
I changed the id back to btx-form-builder and everything is working fine now and our forms are using the right routed template.

Offline

#6 September 22, 2016 3:34pm

timbuckingham
Administrator
From: Baltimore, MD
Registered: April 2, 2012
Posts: 932

Re: Upgraded Form Builder and now using default styling

Sounds good! Make sure you delete the "extension" column of the template or you'll probably run into the same issue again.

Offline

#7 September 22, 2016 3:42pm

doon.mok
Member
Registered: May 6, 2015
Posts: 96

Re: Upgraded Form Builder and now using default styling

Thanks Tim, we deleted the com.fastspot.form-builder from the extension column as well.

Offline

Board footer

Powered by FluxBB

The Discussion Forum is not available on displays of this size.